AlbaHost Service Status / AlbaHost Statusi Sherbimeve - Partial Power Outage – InterWerk Data Center – Incident details

All systems operational

AlbaHost Service Status / AlbaHost Statusi Sherbimeve

Partial Power Outage – InterWerk Data Center

Resolved
Operational
Started 29 days agoLasted about 4 hours

Affected

Other Notifications

Partial outage from 7:20 AM to 8:43 AM, Operational from 8:43 AM to 11:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Update – 09:28 a.m.:


    One of the UPS units failed to bridge the power interruption correctly. As a result, several network switches sustained damage. Our team is currently replacing and testing affected hardware. Please note that troubleshooting and restoration may take several hours. We kindly ask for your patience.

    Update – 10:31 a.m.:


    If your systems are still unavailable, please don’t hesitate to contact us via email or ticket. We will prioritize and immediately check the status of your system.


    We sincerely apologize for the inconvenience and appreciate your understanding. Further updates will follow as soon as new information becomes available.

  • Investigating
    Investigating

    Dear Customer,

    We would like to inform you that a partial power outage occurred in our InterWerk data center on 04.07.2025 at 08:07 a.m.

    Our technical team is actively working to resolve the issue and is currently conducting a thorough investigation into the cause and the impact. According to initial assessments, the power disruption was brief but did affect a limited number of systems.

    We understand the importance of uninterrupted service and sincerely apologize for any inconvenience caused. Further updates will be shared as soon as more details become available.

    Thank you for your understanding and patience.

    Best regards,

    AlbHost.